冰楓論壇

 找回密碼
 立即註冊
查看: 392|回覆: 0

汇编读写自身内存

[複製鏈接]

9

主題

0

好友

4

積分

新手上路

Rank: 1

UID
233685
帖子
12
主題
9
精華
0
積分
4
楓幣
9
威望
4
存款
0
贊助金額
0
推廣
0
GP
5
閱讀權限
10
性別
保密
在線時間
1 小時
註冊時間
2018-5-1
最後登入
2019-6-14
發表於 2018-5-25 16:57:24 |顯示全部樓層
.版本 2
.支持库 spec
.子程序 asm_写整型内存, 逻辑型, 公开, 汇编写自身内存
.参数 内存地址, 整数型
.参数 内容, 整数型
置入代码 ({ 139, 77, 12, 139, 69, 8, 137, 8, 139, 229, 93, 195 })
返回 (假)
.子程序 asm_读整型内存, 整数型, 公开, 汇编读自身内存
.参数 读取地址, 整数型
置入代码 ({ 139, 68, 36, 8, 61, 0, 0, 16, 0, 126, 8, 133, 192, 116, 4, 139, 0, 235, 5, 184, 255, 255, 255, 255, 139, 229, 93, 194, 4, 0 })
返回 (-1)

.子程序 asm_读短整型内存, 整数型, 公开, 汇编读自身内存
置入代码 ({ 139, 68, 36, 8, 61, 0, 0, 16, 0, 126, 9, 133, 192, 116, 5, 15, 183, 0, 235, 5, 184, 255, 255, 255, 255, 139, 229, 93, 194, 4, 0 })
返回 (-1)
[發帖際遇]: shakesaell 與「兩姊弟」穿名牌在臉書炒新聞、裝可憐賣「布丁」,大賺 1 楓幣. 幸運榜 / 衰神榜
您需要登入後才可以回帖 登入 | 立即註冊

正在連接伺服器...
打開冰楓聊天室
廣告刊登意見回饋關於我們職位招聘

Copyright © 2011-2019 冰楓論壇, All rights reserved

免責聲明:本網站是以即時上載留言的方式運作,本站對所有留言的真實性、完整性及立場等,不負任何法律責任。

而一切留言之言論只代表留言者個人意見,並非本網站之立場,用戶不應信賴內容,並應自行判斷內容之真實性。

小黑屋|意見反饋|手機版|Archiver|冰楓論壇

GMT+8, 2019-8-25 21:11

APP Store下載 Play Store下載
回頂部